$re = '/(?sm)^aaa$(.*?)^bbb$/';
$str = 'aaa
test
test
test
test
bbb
aaa
test
test
bbb
aaa
test
test
test
test
test
test
bbb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);