const regex = /<a href="([^"]+)" target="([^"]+)" rel="([^"]+)" title="([^"]+)">([^<]+)<\/a>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="([^"]+)" target="([^"]+)" rel="([^"]+)" title="([^"]+)">([^<]+)<\\\/a>', 'gi')
const str = `test <a href="http://www.un-site.com/page.html" target="_blank" rel="nofollow" title="Mon site">Cliquez sur ce lien</a> test
test <a href="http://www.un-site2.com/page2.html" target="_new" rel="nofollow" title="Mon site2">Cliquez sur ce lien 2</a> test
test <a href="http://www.un-site3.com/page3.html" target="_parent" rel="nofollow" title="Mon site3">Cliquez sur ce lien 3</a> test
test <a href="http://www.un-site4.com/page4.html" target="frame" rel="nofollow" title="Mon site4">Cliquez sur ce lien 4</a> test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}