import Foundation
let pattern = #"<a href="([^"]+)" target="([^"]+)" rel="([^"]+)" title="([^"]+)">([^<]+)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
test <a href="http://www.un-site.com/page.html" target="_blank" rel="nofollow" title="Mon site">Cliquez sur ce lien</a> test
test <a href="http://www.un-site2.com/page2.html" target="_new" rel="nofollow" title="Mon site2">Cliquez sur ce lien 2</a> test
test <a href="http://www.un-site3.com/page3.html" target="_parent" rel="nofollow" title="Mon site3">Cliquez sur ce lien 3</a> test
test <a href="http://www.un-site4.com/page4.html" target="frame" rel="nofollow" title="Mon site4">Cliquez sur ce lien 4</a> test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)