$re = '/[^=]+==/m';
$str = 'window.location.href=\'https://example.me/bot_v2?start=b8Kko9LCo8KZwqhSwqTCncKwU8yrwqRQw4TCo9Kcwp_C78KbWA==\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);