$re = '/.*(?!p\.? *o\.? *box).*/im';
$str = 'this is a match
this is not a match beause of p.o. box
pobox';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);