re = /.*(?!p\.? *o\.? *box).*/im
str = 'this is a match
this is not a match beause of p.o. box
pobox'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end