import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!-|.*(\\.[.-]|-\\.|-$))(?:[A-Z0-9-]{0,62}\\.){1,8}[A-Z0-9]{3}$";
final String string = "www.-site.com\n"
+ "www.site-.com\n"
+ "www.site.com\n"
+ "www.site..com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}