re = /^(?:\d+\.\d+\.(?:\d+\.)*(?=.*\n\d+\.\d+\.(?:\d+\.)*)|\d+\.\d+\.(?:\d+\.)*(?!.*\n))/m
str = '1.2.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end