using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?=\d{7,9}$)[01]?|\d*(?=\d{7}$)|)(\d+$)";
string input = @"555123
1234567
5551212
5551234567
12345
1234
123
12
1
012345678
1234567
0123456789
12345678900123124
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}