$re = '/^(?:(?=\d{7,9}$)[01]?|\d*(?=\d{7}$)|)(\d+$)/m';
$str = '555123
1234567
5551212
5551234567
12345
1234
123
12
1
012345678
1234567
0123456789
12345678900123124
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);