import re
regex = re.compile(r"\d{3}-\d{3}")
test_str = "+1-703-535-1039 +1-703-728-8382 +1-703-638-1039 +1-703-535-1039 "
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")