const regex = /([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4})\s([0-9]{1,2}):([0-9]{1,2})\s([0-9]{1,2}):([0-9]{1,2})\s([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\-([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{1,2})\\\/([0-9]{1,2})\\\/([0-9]{4})\\s([0-9]{1,2}):([0-9]{1,2})\\s([0-9]{1,2}):([0-9]{1,2})\\s([A-Za-z]+)\\s([A-Za-z]+)\\s([A-Z]{2})\\-([0-9]+)', 'g')
const str = `13/03/2016 14:55 18:55 Frankfurt Izmir XQ-971 A-AOW9 SunEco HK 30
13/03/2016 20:10 22:05 Izmir Trabzon XQ-9270 S-ADD
31/03/2016 12:00 13:50 Trabzon Antalya XQ-7619 S-ADD
31/03/2016 15:00 17:45 Antalya Frankfurt XQ-140 Z-ZOW8 SunEco HK 30
SunEco HK 30
ON
SunEco HK 30
ON`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}