$re = '/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{4})\s([0-9]{1,2}):([0-9]{1,2})\s([0-9]{1,2}):([0-9]{1,2})\s([A-Za-z]+)\s([A-Za-z]+)\s([A-Z]{2})\-([0-9]+)/';
$str = '13/03/2016 14:55 18:55 Frankfurt Izmir XQ-971 A-AOW9 SunEco HK 30
13/03/2016 20:10 22:05 Izmir Trabzon XQ-9270 S-ADD
31/03/2016 12:00 13:50 Trabzon Antalya XQ-7619 S-ADD
31/03/2016 15:00 17:45 Antalya Frankfurt XQ-140 Z-ZOW8 SunEco HK 30
SunEco HK 30
ON
SunEco HK 30
ON';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);