const regex = /^false_(.*)_(.*)_(.*)$/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^false_(.*)_(.*)_(.*)$', 'gs')
const str = `false_120363047103977256@g.us_B09C4B168CF6EE28B86C78C1E451E2B1_79036185705@c.us`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}