import re
regex = re.compile(r"^false_(.*)_(.*)_(.*)$", flags=re.DOTALL)
test_str = "false_120363047103977256@g.us_B09C4B168CF6EE28B86C78C1E451E2B1_79036185705@c.us"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")