const regex = /([A-G]{1})(\#|b{1})?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-G]{1})(\\#|b{1})?', '')
const str = `D
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}