$re = '/([A-G]{1})(\#|b{1})?/x';
$str = 'D
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);