#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!%%)%(?:(?!%{2}|c%)[%DCS-])+$"
Local $sString = "%DCS" & @CRLF & _
"%D%S" & @CRLF & _
"%D--S" & @CRLF & _
"%D%%S" & @CRLF & _
"%%DCS" & @CRLF & _
"%CCS" & @CRLF & _
"DSC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")