$re = '~^.*?//.*?(?=//)~m';
$str = 'C#//text with any symbols */\\ even digits 97878//Other don\'t need // text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);