re = /^.*?\/\/.*?(?=\/\/)/m
str = 'C#//text with any symbols */\\ even digits 97878//Other don\'t need // text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end