package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/$`)
var str = `this/DOES/NOT/have/a/trailing/forward/slash
this/DOES/have/a/trailing/forward/slash/
this/DOES/NOT/have/a/trailing/forward/slash
this/DOES/have/a/trailing/forward/slash/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}