$re = '/\/$/m';
$str = 'this/DOES/NOT/have/a/trailing/forward/slash
this/DOES/have/a/trailing/forward/slash/
this/DOES/NOT/have/a/trailing/forward/slash
this/DOES/have/a/trailing/forward/slash/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);