package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b0+\B`)
var str = `0000000000456789 Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim 00034ad minim veniam 00, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute 00210023332323322 irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}