const regex = /\b0+\B/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b0+\\B', 'mg')
const str = `0000000000456789 Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim 00034ad minim veniam 00, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute 00210023332323322 irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);