const regex = /((?<raute>#(?<raute_content>[^\n]*))|(?<doubleslashes>\/\/(?<doubleslashes_content>[^\n]*))|(?<block>\/\*(?<block_content>[^*]+|\*(?!\/))*+\*\/))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<raute>#(?<raute_content>[^\\n]*))|(?<doubleslashes>\\\/\\\/(?<doubleslashes_content>[^\\n]*))|(?<block>\\\/\\*(?<block_content>[^*]+|\\*(?!\\\/))*+\\*\\\/))', 'gm')
const str = `blah
# ein Kommentar
blah blah // ein Kommentar
/*
Ein
Kommentar
Block
*/
blah # ein weiteres Kommentar
blah
/* Zweiter Block
Geht wieder über mehrere Zeilen */
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}