import re
regex = re.compile(r"((?<raute>#(?<raute_content>[^\n]*))|(?<doubleslashes>\/\/(?<doubleslashes_content>[^\n]*))|(?<block>\/\*(?<block_content>[^*]+|\*(?!\/))*+\*\/))", flags=re.MULTILINE)
test_str = ("blah\n"
"# ein Kommentar\n"
"blah blah // ein Kommentar\n\n"
"/*\n"
" Ein\n"
"Kommentar\n"
" Block\n\n\n"
"*/\n\n"
"blah # ein weiteres Kommentar\n\n"
"blah\n\n"
"/* Zweiter Block\n\n"
"Geht wieder über mehrere Zeilen */\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")