package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*`)
var str = `azA_Z_09`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}