$re = '/[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*/';
$str = 'azA_Z_09';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);