$re = '/([a-z]*)(?=.*[0-9])(?=.*[A-Z])(?=.*[\W])(?!.*[\s])(^.{8,16})/m';
$str = 'Test34Rest#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);