re = /([a-z]*)(?=.*[0-9])(?=.*[A-Z])(?=.*[\W])(?!.*[\s])(^.{8,16})/m
str = 'Test34Rest#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end