using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"licensePlate\=(?<licensePlate>[^ ]+)";
string input = @"[Information] WebService Call CheckVehicle : country=111111, licensePlate=12DUMMY";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}