$re = '/licensePlate\=(?<licensePlate>[^ ]+)/m';
$str = '[Information] WebService Call CheckVehicle : country=111111, licensePlate=12DUMMY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);