using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(Merged PR \d+: \))?([a-zA-Z]+)(?:\(([\w$\.\-*\s]*)\))?\!?:(.*)";
string input = @"Merged PR 6359: fix(credit): delete split schedule even if the contract was already closed - PREPROD
Merged PR 6359: fix(): delete split schedule even if the contract was already closed - PREPROD
Merged PR 6359: fix: delete split schedule even if the contract was already closed - PREPROD
headerPattern: /^(\w*)(?:\(([\w$.\-* ]*)\))?: (.*)$/,
headerCorrespondence: ['type', 'scope', 'subject'],
fix: ON-00 Change topic to ab command topic for AZF
fix(credit): ON-00 Change topic to ab command topic for AZF
fix(credit):ON-00 Change topic to ab command topic for AZF
Change topic to ab command topic for AZF
feat!: send an email to the customer when a product is shipped
feat(api)!: send an email to the customer when a product is shipped";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}