import re
regex = re.compile(r"(?:\(Merged PR \d+: \))?([a-zA-Z]+)(?:\(([\w$\.\-*\s]*)\))?\!?:(.*)")
test_str = ("Merged PR 6359: fix(credit): delete split schedule even if the contract was already closed - PREPROD\n\n"
"Merged PR 6359: fix(): delete split schedule even if the contract was already closed - PREPROD\n\n"
"Merged PR 6359: fix: delete split schedule even if the contract was already closed - PREPROD\n\n"
"headerPattern: /^(\\w*)(?:\\(([\\w$.\\-* ]*)\\))?: (.*)$/,\n"
" headerCorrespondence: ['type', 'scope', 'subject'],\n\n\n"
"fix: ON-00 Change topic to ab command topic for AZF\n\n"
"fix(credit): ON-00 Change topic to ab command topic for AZF\n"
"fix(credit):ON-00 Change topic to ab command topic for AZF\n"
"Change topic to ab command topic for AZF\n\n"
"feat!: send an email to the customer when a product is shipped\n"
"feat(api)!: send an email to the customer when a product is shipped")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")