using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(ham|turkey)";
string input = @"reuben sandwich with ham and turkey ham sandwich with cheese
reuben sandwich with turkey and ham ham sandwich with cheese
reuben sandwich with ham and ham ham sandwich with cheese
reuben sandwich with forbidden ham and turkey ham sandwich with cheese
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}