$re = '/sandwich((?:(?!forbidden).)*?)(ham|turkey)(.*?)(ham|turkey)/';
$str = 'reuben sandwich with ham and turkey ham sandwich with cheese
reuben sandwich with turkey and ham ham sandwich with cheese
reuben sandwich with ham and ham ham sandwich with cheese
reuben sandwich with forbidden ham and turkey ham sandwich with cheese
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);