# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(text[ ]*=[ ]*)'(((?!item_1[,]?).)*)'"
test_str = ("text = ''\n\n"
"text = 'a'\n\n"
"text = 'a,b,c,d'\n\n"
"text = 'item_1,a'\n\n"
"text = 'item_1,a,b'\n\n"
"text = 'a,b,item_1'\n\n"
"text = 'a,item_1,b'\n\n"
"text = 'a,item_1'\n\n"
"text = 'item_1,item_1'\n\n"
"text = 'item_1'")
subst = "\\1'item_1,\\2'"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.