import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<number>\\d+)\\s+(?P<Item_Name>\\w+)\\s+(?P<code>[a-zA-Z]{0,3})\\s+(?P<status>SOLD|SALE|PURCHASED)";
final String string = "99 ITEM SEC SALE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}