re = /((?:[a-zA-Z0-9]{2}[:-]){5}[a-zA-Z0-9]{2})/
str = 'Jul 11 18:09:06 ? user.info shepherd[366]: fifo: 8C:C1:21:A2:44:A3 is being marked undiscovered from state IS_IM_UNDELIV_DEST_UNDISC_MARKER_CLEAR by port removal'
# Print the match result
str.match(re) do |match|
puts match.to_s
end