using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]([^\[\]]+)\[";
string input = @"[size=24][b][i][color][font]заголовок sdfsdfsdf ЗАГОЛ eng[/font][/color][/i][/b][/size]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}