$re = '/\]([^\[\]]+)\[/';
$str = '[size=24][b][i][color][font]заголовок sdfsdfsdf ЗАГОЛ eng[/font][/color][/i][/b][/size]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);