package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https|ftp|http):\/\/[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?`)
var str = `http://example.com/tr/vvf/index.php/docs/po/trf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}