re = /(https|ftp|http):\/\/[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?/
str = 'http://example.com/tr/vvf/index.php/docs/po/trf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end