using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(password|secret|api[_-]?key)\b\s*[:=]\s*(?!\s*\$\{)(?!\s*process\.env\b)(?:['""])?[A-Za-z0-9!*@#$%^&*()_+=-]{5,}(?:['""])?";
string input = @"password: mysimplename
password: ${mysimplename23}
apikey: mysimplename45
password: process.env.DB_PASSWORD
password: someVariable
password: ""someVariable""
secret: process.env.DB_PASSWORD
password: someVariable
password: ""someVariable""
api_key: ${mysimplename45}
apikey: mysimplename45
secret: mayClearPassword
secret: process.env.DB_PASSWORD
secret: env.DB_PASSWORD
api_key: env.DB_PASSWORD
apikey: ""${mysimplename45}""
api_key: ""$mysimplename45""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}