import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b(password|secret|api[_-]?key)\\b\\s*[:=]\\s*(?!\\s*\\$\\{)(?!\\s*process\\.env\\b)(?:['\"])?[A-Za-z0-9!*@#$%^&*()_+=-]{5,}(?:['\"])?";
final String string = "password: mysimplename\n"
+ "password: ${mysimplename23}\n"
+ "apikey: mysimplename45\n"
+ "password: process.env.DB_PASSWORD\n"
+ "password: someVariable\n"
+ "password: \"someVariable\"\n"
+ "secret: process.env.DB_PASSWORD\n"
+ "password: someVariable\n"
+ "password: \"someVariable\"\n"
+ "api_key: ${mysimplename45}\n"
+ "apikey: mysimplename45\n"
+ "secret: mayClearPassword\n"
+ "secret: process.env.DB_PASSWORD\n"
+ "secret: env.DB_PASSWORD\n"
+ "api_key: env.DB_PASSWORD\n"
+ "apikey: \"${mysimplename45}\"\n"
+ "api_key: \"$mysimplename45\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}