re = /^((([01]\d)|20|21|22|23)):([0-5][0-9])$/mx
str = '00:00
00:01
01:00
03:33
09:09
10:10
19:45
20:43
23:59
213:56
23:60
23:99
24:00
29:00
99:00
99:99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end