// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^((([01]\d)|20|21|22|23)):([0-5][0-9])$").unwrap();
let string = "00:00
00:01
01:00
03:33
09:09
10:10
19:45
20:43
23:59
213:56
23:60
23:99
24:00
29:00
99:00
99:99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}