import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^%(\\w{3})\\s+(\\d+)\\s*([0-9]+\\s?:\\s?[0-9]+\\s?:\\s?[0-9]+):[0-9]+\\s*(\\d{4})?\\s*\\S*\\s*(.*)/(\\d+)/\\S*:(?:(.*);)?(.*)";
final String string = "%May 11 10:03:51:122 2000 AB-CD-E SSH/6/SSH_LOGOUT: STEL user manager (IP: 172.0.0.0) logged out.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}