re = /^%(\w{3})\s+(\d+)\s*([0-9]+\s?:\s?[0-9]+\s?:\s?[0-9]+):[0-9]+\s*(\d{4})?\s*\S*\s*(.*)\/(\d+)\/\S*:(?:(.*);)?(.*)/
str = '%May 11 10:03:51:122 2000 AB-CD-E SSH/6/SSH_LOGOUT: STEL user manager (IP: 172.0.0.0) logged out.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end