using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"access_token=(.*?)&expires=\d+";
string input = @"access_token=CAABletmsJHgBAEMfdJEgA1wEXgqwVgfM1nrTgyHq9XxkIEvLVGOUMq80ZBaA2ZA6Ndc18xNwZAJCDwpILNSKgGiVu4SIm9B0K5ocv7ZCVFV1bxKrNW9qrIqK1HKIz3uD6nO4RQnVgfVmLggoqZCVkPwjEY79ijZC0SYKPYM2RN9qg4TZB5E2iMz5WfAAACddAbXaEZCbzkBSoSZBTlEyea8rC&expires=5181509";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}